Limetime's TimeLine
article thumbnail
반응형

IGRP


- Cisco 전용 프로토콜

- Distance-Vector Algorithm

- IGP (Interior Gateway Protocol, RIP과 EIGRP 등이 있다.)

 

IGRP의 특징


① 내부용(IGP) Dynamic Routing Protocol이며 Distance-Vector 알고리즘을 사용한다.

② 라우팅 테이블 업데이트 주기 : 90초

③ Default Hop Count : 100 (최대 255까지 확장 가능)

④ VLSM(Variable Length Subnet Network)를 지원하지 않는다.

     - ex) 포트에 150.150.100.1 255.255.255.0을 주고 EIGRP 설정에서 network 150.150.100.0을 해도 실제로는 150.150.0.0이 들어간 것을 show run으로 볼 수 있다.

⑤ RIP처럼 홉(Hop) 카운트로만 경로를 따지지 않는다. 아래의 5가지를 참조하여 결정한다.

IGRP에서 경로 찾기

반응형

     1. Bandwidth(대역폭) : 값의 단위는 kbps (Serial 기본 대역폭은 1.544Mbps(1,544kbps))

         - 해당 포트로 가서 직접 bandwidth 명령어로 넣어주고 show interface 명령어로 확인 가능하다.

         - ex) int s 0 → bandwidth 56 (<1~10000000> Bandwidth in kilobits)

         * 대역폭은 속도이지만 올린다고 해서 라우터 자체나 회선 속도(물리적 속도)가 빨리지지는 않는다. 다만 최적 경로를 찾는데에 이용할 뿐이다.

      2. Delay(지연) : 경로를 통해서 도착할 때까지의 지연되는 시간 (단위 : μsec(micro second), 1 ~ 16,777,215)

          - 원래 이 값은 회선에 아무 트래픽이 없을 때를 가정하고 제공되는 수치

          - IGRP는 라우터 포트에 연결되어 있는 회선의 종류와 설정된 대역폭 값에 따라서 지연 값을 계산한다.

          * 거의 Default로 값을 둔다. (다른 변수를 바꾸는게 더 유용하기 때문!)

      3. Reliability(신뢰성) : 케이블이나 전용선 등 전송매체를 통해 패킷을 보낼 때 생기는 에러율 수치이다.

          - 목적지까지 제대로 간 패킷과 에러난 패킷의 비율

          - Keepalive로 출발지와 목적지 사이 경로의 신뢰도 측정 (0 ~ 255, 255에 가까울 수록 신뢰도가 높다.)

          * 이 값은 자동으로 계산된다.

      4. Load(부하) : 출발지와 목적지 경로에 어느 정도의 부하가 걸리는지 측정한다.

          - 몇/255, 1/255이면 부하가 적은 것이고 255/255(=1)이면 부하가 많은 것이다.

          - 즉, 0에 가까울 수록 부하가 적고, 1에 가까울 수록 부하가 크다.

      5. MTU(Maximum Transmission Unit) : 경로의 최대 전송 유닛의 크기, Byte로 표시

 

결론


- Hop Count가 15를 초과하면 안되는 RIP에 비해, 최대 255개의 널널한 Hop Count를 사용 가능하다. 게다가 Hop Count만 가지고 경로를 찾는 RIP 보다 더 지능적이다.

- 단, CISCO 장비에서만 사용 가능한 전용 프로토콜이다.

 

실습1


RouterA(config)# int e0
RouterA(config-if)# ip addr 203.240.100.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# int se0
RouterA(config-if)# ip addr 203.240.150.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# router igrp 200
RouterA(config-router)# network 203.240.100.0
RouterA(config-router)# network 203.240.150.0

*AS(Autonomous System) Number(그룹)가 같아야 통신이 된다. (물론 달라도 되게하는 방법이 있다.)

   - router igrp 200이므로 AS 넘버는 '200'

RouterB(config)# int e0
RouterB(config-if)# ip addr 203.240.200.1 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# exit
RouterB(config)# int se0
RouterB(config-if)# ip addr 203.240.150.2 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# exit
RouterB(config)# router igrp 200
RouterB(config-router)# network 203.240.200.0
RouterB(config-router)# network 203.240.150.0

RouterA# show ip protocol

* 만약 RIP과 IGRP 2개의 경로가 들어 왔다면, 디스턴스 값이 적은 IGRP 경로가 더 우선한다.

 

RouterA# show ip route (라우팅 테이블)

 

실습2


RouterC(config)# int e0
RouterC(config-if)# ip addr 150.150.1.1 255.255.0.0
RouterC(config-if)# no shutdown
RouterC(config-if)# exit
RouterC(config)# int se0
RouterC(config-if)# ip addr 203.210.200.2 255.255.255.0
RouterC(config-if)# no shutdown
RouterC(config-if)# exit
RouterC(config)# router igrp 200
RouterC(config-router)# network 150.150.0.0
RouterC(config-router)# network 203.210.200.0
RouterA(config)# int fa0/0
RouterA(config-if)# ip addr 210.240.10.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# int se2/1
RouterA(config-if)# ip addr 203.210.200.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# int se2/0
RouterA(config-if)# ip addr 203.210.100.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# router igrp 200
RouterA(config-router)# network 210.240.10.0
RouterA(config-router)# network 203.210.200.0
RouterA(config-router)# network 203.210.100.0
RouterB(config)# int se0
RouterB(config-if)# ip addr 203.210.100.2 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# exit
RouterB(config)# int e0
RouterB(config-if)# ip addr 172.70.100.1 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# exit
RouterB(config)# router igrp 200
RouterB(config-router)# network 203.210.100.0
RouterB(config-router)# network 172.70.100.0

RouterC# show ip route
RouterB# show ip route
RouterB# show ip protocol
RouterB# show ip interface
RouterB# IGRP 디버그

 

 

 

IGRP - Passive Interface


- IGRP 라우팅 업데이트가 특정 인터페이스로는 날아가지 않도록하는 명령어

① Ethernet 0/1은 IP가 160.100.1.1이고 C클래스(255.255.255.0)이다. IGRP 프로토콜

     Ethernet0/0은 IP가 160.100.2.1이고 C클래스(255.255.255.0)이다. OSPF 프로토콜

② show run 명령어로 보았을 때, 아래와 같다.

router ospf 10
	network 160.100.2.0 0.0.0.255 area 0
router eigrp 200
	network 160.100.0.0

- OSPF는 VLSM을 지원하여 160.100.2.0 네트워크만 포함하는 반면, IGRP는 서브넷 정보를 포함하지 않아 160.100.0.0 네트워크를 모두 포함한다.

- 그래서 OSPF 라우팅 정보 뿐만 아니라 필요없는 IGRP 정보도 Ethernet 0/0으로 보내준다.

③ Passive Interface는 불필요한 IGRP 라우팅 정보를 Ethernet0/0으로 보내지 않는다!

router igrp 200
     network 160.100.0.0
     passive interface Ethernet 0/0

 

반응형
profile

Limetime's TimeLine

@Limetime

포스팅이 좋았다면 "공감❤️" 또는 "구독👍🏻" 해주세요!