반응형
Default Route
- 경로를 찾아내지 못한 모든 네트워크들은 모두 이곳으로 가라고 미리 정해 놓은 길
- ex) 인터넷을 사용하는 라우터, Stub 네트워크에 속한 라우터
① Default-Network를 사용한 디폴트 라우트
※ 하나라도 어긋나면 동작하지 않는다!
- 네트워크 주소는 항상 클래스에 맞추어야 한다.(203.240.10.0 = C클래스)
- ex) ip default-network 150.100.1.0 (X)
- ex) ip default-network 150.100.0.0 (O)
- RIP에서 디폴트 네트워크를 구성하는 경우 네트워크 주소를 반드시 RIP 프로토콜에서 정의된 네트워크로 지정해야 한다. (단, IGRP의 경우 절대로 IGRP 프로토콜이 돌지 않은 네트워크를 지정해야 한다.
② Static Routing을 사용한 디폴트 라우트 (★권장!)
※ Serial0이 203.240.10.1로 가는 인터페이스라는 가정.
- ip route 0.0.0.0 0.0.0.0 203.240.10.1 → 길 못찾으면 다 203.240.10.1로 가라.
- = ip route 0.0.0.0 0.0.0.0 serial0 → 길 못찾으면 다 serial0으로 가라
사례 1.
가정
- 라우팅 프로토콜은 돌고 있지 않은 상황
반응형
Router# show running-config
Building Configuration...
Current Configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable password cisco
!
ip subnet-zero// 앞 쪽 서브넷을 사용하기 위한 명령
// (원래 서브넷을 만들면 맨 앞과 맨 뒤 서브넷은 버린다.) => 서브넷 부분에 전부 0을 넣어 만든 것.
ip name-server 164.111.101.2 // DNS 서버
ip name-server 203.222.252.2
!
!
!
interface Ethernet0
ip address 210.150.100.1 255.255.255.192
// 서브넷 네트워크 주소 : 210.150.100.0
// 부여가능 주소 : 210.150.100.1 ~ 62
no ip directed-broadcast
!
interface serial0
ip address 210.180.100.178 255.255.255.252
no ip directed-broadcast
no ip mrout-cache
!
interface serial1
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 serial0 // IP 트래픽 중 밖으로 나가려는 모든 패킷은 Serial0으로 보내라
! => ip route 0.0.0.0 0.0.0.0 210.180.100.177 (만약 다른 라우팅 프로토콜이 있다면 라우팅테이블 안에서 먼저 경로를 찾고 찾지 못한 패킷만 Serial0으로 보낸다.)
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
사례 2.
가정
- 다이나믹 라우팅 프로토콜 X
- 라우터 A에 설정(Router_A)
- 150.150.0.0 (255.255.0.0) 네트워크에 접속 가능할 것
- 나머지 모든 트래픽은 Default로 인터넷 쪽으로 나갈 수 있도록 할 것.
구성
Router_A(config)# int fa 0/0
Router_A(config-if)# ip address 210.240.10.1 255.255.255.0
Router_A(config-if)# no shutdown
Router_A(config-if)# exit
Router_A(config)# int se 2/0
Router_A(config-if)# ip add 203.210.100.1 255.255.255.0
Router_A(config-if)# no shutdown
Router_A(config-if)# clockrate 128000 // 라우터와 라우터를 V.35 케이블로 직접 연결할 때는 항상 DCE 쪽에서 클럭을 설정해줘야 한다.
Router_A(config-if)# exit
Router_A(config)# int se 2/1
Router_A(config-if)# ip addr 203.210.200.1 255.255.255.0
Router_A(config-if)# clockrate 128000
Router_A(config-if)# no shutdown
Router_A(config-if)# clockrate 128000
Router_A(config-if)# exit
Router_A(config)# ip route 0.0.0.0 0.0.0.0 203.210.100.2 // 디폴트 네트워크 설정
Router_A(config)# ip route 150.150.0.0 255.255.0.0 203.210.200.2 // 150.150.0.0 네트워크에 가려면 203.210.200.2로 가라
Router_A(config)# exit
구성 확인
Router_A# show int se 2/0
Serial 2/0 is up, line protocol is up
Hardware is M4T
Internet address is 203.210.100.1/24
...
Router_A# ping 203.210.100.2 // Ping 성공 (Basic or Standard ping)
TYPE escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.210.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 Percent (5/5), round-trip min/avg/max = 16/16/16 ms
Router_A# show ip route
codes: I - IGRP derived, R - RIP derived, O - OSPF derived
C - Connected, S - Static, E - EGP derived, B - BGP derived
i - IS-IS derived, D - EIGRP derived
* - Candidate default route, IA - OSPF inter area route
E1 - OSPF external type1 route, E2 - OSPF external type2 route
L1 - IS-IS level-1 route, L2 - IS-IS level-2 route
EX - EIGRP external route
Gateway of least resort is 203.210.100.2 to network 0.0.0.0 // 디폴트 라우팅을 설정한 경우만 표시. 갈 곳 없는 패킷들의 마지막 경로
// 즉, 무조건 203.210.100.2로 가라는 것.
C 203.210.200.0/24 is directly connected, serial 2/1
C 203.210.100.0/24 is directly connected, serial 2/0
C 210.240.10.0/24 is directly connected, FastEthernet 0/0
S 150.150.0.0/16 [1/0] via 203.210.200.2 // Static Routing. 16bit Mask (255.255.0.0)
S* 0.0.0.0/0 [1/0] via 203.210.100.2 // Default Route + Static Routing
// 즉, 150.150.0.0을 제외한 모든 트래픽은 203.210.100.2로 가라는 뜻.
Router_A# ping 150.150.1.1
TYPE escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.150.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 Percent (5/5), round-trip min/avg/max = 4/4/4 ms
Router_A# ping 172.70.100.1
TYPE escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.70.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 Percent (5/5), round-trip min/avg/max = 16/16/16 ms
반응형